Tutorial Activar smb en Windows 10 y compartir archivos o discos duros

Koji

Miembro 1080i
Registrado
26 Julio 2019
Hola, pues yo también estoy liado con el tema.

Resulta que estaba con orange y con su router no tuve ningún problema para conectar y que el chinoppo me pillara la red del PC y por tanto la carpeta compartida de Drive. Pues bien, hace unos días cambié de compañía y de Router, y desde entonces no hay forma. Es más, he instalado un W7 en un portátil y tampoco me lo pilla. Eso sí, cuando reinicio el router (valores de fábrica) suele cogerme el w7 y alguna vez el w10 , pero al apagar, se pierde.
Tras tocar, y dar trescientas vueltas a todo, pensé en poner el router de orange, para hacer la red local solamente. Y al ponerlo, me coge todo perfectamente. Por tanto, conclusión: el router nuevo falla o le falta algo.
He seguido dándole vueltas, y ahora mismo, casi por casualidad, tras crear otra partición y hacer instalación limpia de w10 (ahora a ver como vuelvo a la otra) y probar y seguir igual, he vuelto a poner el router de orange y al cogerlo, he entrado en la configuración y me he dado cuenta de una cosa, tiene una opción que será para activar un NAS, pues bien,, la he desactivado, he guardado configuración y … El chinoppo ya no me coge la red de samba del PC. Vuelta a activar y vuelta a cogerla.

Si podéis mirar en vuestro router a ver si tiene esa opción y podéis activarla. A ver si tenéis más suerte, porque el router que me han puesto nuevo no la tiene. Voy a mirar a ver que tienen otro por ahí (Orbiter creo) a ver si lleva esa opción y pido el cambio. El que tengo ahora es un ZTE pero creo que viene capado en casi todo y esa opción no la trae.

Un saludo, me contáis si os ha funcionado.
 

demonlove

Miembro 480p
Registrado
9 Octubre 2019
To tengo el HGU de Telefónica y no veo ninguna opción parecida a la que comentas. Vaya lío más gordo este tema...bufff...
A mi me sigue funcionando como comenté más atrás. De todas formas, estoy mirando un Synology, el más básico que tienen que vale poco más de 100 euros y que creo qu para el uso que lo voy a dar me sobraría, pero de momento, voy a tirar con lo que tengo. De momento...
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
Pues yo sigo intentándolo, incluso me planteo volver a orange que con su router me funciona.

De todas formas pienso que tiene que ser algo del Router. Porque que dije, al poner el liveplus de orange el chinoppo me lo coge enseguida. También he probado uno de Masmovil, aunque aquí la cosa se complica porque para que me lo reconozca el chinoppo tengo que activar el samba del router y para que esté activo tiene que tener un usb en el puerto del router, pero aunque sea de esta forma, lo coge. Con el router que tengo ahora, un ZTE, he conseguido que me lo coja, pero tengo que tener el portátil con W7 encendido a la vez que el PC y tengo que hacer un reset de fábrica al router. En ese momento, en cuando arranca, coge los dos ordenadores, pero si apago el portátil pierdo el PC, y si ya apago y vuelvo a encender los ordenadores, ya no hay forma de que lo vuelva a coger. Si con los dos ordenadores apago el chinoppo o el router, no hay problema, sigue cogiéndolos, el problema es apagar el portátil.
Es más, he probado a poner el router de orange por cable al router ZTE nuevo sin configurar nada, todo directo y el chinoppo me coge la red samba cuando reconoce el de orange (va cambiando de uno a otro).

En fin, es raro, a ver si haciendo pruebas, o alguien más entendido en el tema, nos puede orientar algo más

Lo siguiente que estoy por hacer es instalar un linux y probar desde linux, pero estoy algo falto de tiempo ya. Comprar yo un router y ponerlo, no sé si se puede hacer y/o cómo .

Un saludo
 

Mostovoi1985

Miembro 1080p
Registrado
9 Abril 2020
Pues yo sigo intentándolo, incluso me planteo volver a orange que con su router me funciona.

De todas formas pienso que tiene que ser algo del Router. Porque que dije, al poner el liveplus de orange el chinoppo me lo coge enseguida. También he probado uno de Masmovil, aunque aquí la cosa se complica porque para que me lo reconozca el chinoppo tengo que activar el samba del router y para que esté activo tiene que tener un usb en el puerto del router, pero aunque sea de esta forma, lo coge. Con el router que tengo ahora, un ZTE, he conseguido que me lo coja, pero tengo que tener el portátil con W7 encendido a la vez que el PC y tengo que hacer un reset de fábrica al router. En ese momento, en cuando arranca, coge los dos ordenadores, pero si apago el portátil pierdo el PC, y si ya apago y vuelvo a encender los ordenadores, ya no hay forma de que lo vuelva a coger. Si con los dos ordenadores apago el chinoppo o el router, no hay problema, sigue cogiéndolos, el problema es apagar el portátil.
Es más, he probado a poner el router de orange por cable al router ZTE nuevo sin configurar nada, todo directo y el chinoppo me coge la red samba cuando reconoce el de orange (va cambiando de uno a otro).

En fin, es raro, a ver si haciendo pruebas, o alguien más entendido en el tema, nos puede orientar algo más

Lo siguiente que estoy por hacer es instalar un linux y probar desde linux, pero estoy algo falto de tiempo ya. Comprar yo un router y ponerlo, no sé si se puede hacer y/o cómo .

Un saludo
Crea una partición con Linux e inténtalo por nfs a ver si te da menos problemas que samba
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
Crea una partición con Linux e inténtalo por nfs a ver si te da menos problemas que samba
Ahora me toca aprender a usar Linux. Voy a intentar por samba y sino por nts. ¿Algún manual para torpes totales en linux?

Aunque lo que no me explico es que poniendo otro router y haciendo solo la red local (dos router diferentes) funciona y con el nuevo no. Se lo achaco más al router que a windows. Pero todo puede ser.
 

Mostovoi1985

Miembro 1080p
Registrado
9 Abril 2020
Yo hice esta pequeña guía para novatos como nosotros, creo que se entiende a la perfección. He ido recopilando info de varias webs y está concentrada en la guía, espero que te ayuda a ti a más gente. Yo perdí día y medio hasta que lo hice funcionar, pero siguiendo esta guía deberías tenerlo funcionando en media hora máximo

https://www.avpasion.com/foro/t/nfs-en-kodi.1772/
 

franjhos

Miembro UHD SDR
Registrado
15 Septiembre 2018
El chinoppo también va por NFS, no te has planteado en ponerlo en Windows y tirar de el?
Si ves que samba es un dolor de cabeza segur router prueba NFS
saludos
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
Yo hice esta pequeña guía para novatos como nosotros, creo que se entiende a la perfección. He ido recopilando info de varias webs y está concentrada en la guía, espero que te ayuda a ti a más gente. Yo perdí día y medio hasta que lo hice funcionar, pero siguiendo esta guía deberías tenerlo funcionando en media hora máximo

https://www.avpasion.com/foro/t/nfs-en-kodi.1772/
Muchas gracias. Iré buscando linux y poco a poco lo instalo y lo voy probando a ver.
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
El chinoppo también va por NFS, no te has planteado en ponerlo en Windows y tirar de el?
Si ves que samba es un dolor de cabeza segur router prueba NFS
saludos
NFS en Windows? Es solo activarlo en características de Windows o hay que hacer algo más? ¿Puede estar activado con el smb o hay que poner uno u otro? Por probar a ver si hay suerte
 

franjhos

Miembro UHD SDR
Registrado
15 Septiembre 2018
Se copian una serie de archivos a una localización de Windows en c por ejemplo, hay que editar un archivo para indicar la ruta o nombres de los hdd que quieres compartir, y hay que indicar que se inicie al arrancar Windows si estás en en grupo de Telegram del chinoppo por allí te pueden ayudar en en eso
Saludos
 

djuarez

Miembro 480p
Registrado
3 Abril 2019
NFS en Windows? Es solo activarlo en características de Windows o hay que hacer algo más? ¿Puede estar activado con el smb o hay que poner uno u otro? Por probar a ver si hay suerte
Buenas,
Usa WinNFSd, muy sencillo.

un saludo
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
Gracias.

Estoy por el grupo del chinoppo, sí, lo encontré buscando como solventar lo del samba.

Voy a buscar información del WinNFSd a ver si soy capaz. Si me atranco os digo.
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
Vale, acabo de probar con WinNFSd y me la vé el chinoppo, pero, ¿Se puede compartir la unidad drive completa? Es que no me lee los nombres completos de las carpetas y se me queda colgado el chinoppo. ¿Hay que esperar a que lea todo el contenido?
 

franjhos

Miembro UHD SDR
Registrado
15 Septiembre 2018
Vale, acabo de probar con WinNFSd y me la vé el chinoppo, pero, ¿Se puede compartir la unidad drive completa? Es que no me lee los nombres completos de las carpetas y se me queda colgado el chinoppo. ¿Hay que esperar a que lea todo el contenido?
Lamentablemente podrás ver tus unidades físicas o hdd en el oppo, pero la unidad virtual de Drive solo a través de samba.
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
Lamentablemente podrás ver tus unidades físicas o hdd en el oppo, pero la unidad virtual de Drive solo a través de samba.
Buenas, con WinNFSd, comparto la carpeta de drive y me la ve el chinoppo, pero hay carpetas que no llega a ver el contenido y las que ve no reproduce.
Si comparto una sola carpeta con la peli, me la ve e intenta reproducirla pero llega al 100% de carga y ahí se queda.

No sé ya que más hacer.

Estoy por cancelar contrato (estoy en los 14 días, lo que no sé es el tema de la portabilidad de los móviles, si tendrá vuelta atrás) y volverme con Orange que me funcionaba con samba y me sigue reconociendo la red samba con su router, pero claro, no tengo internet y no puedo reproducir de drive. Me han hablado de poner el router en cascada pero ni idea de qué es ni como se hace y si tendría internet.
 

manuelrn

Administrador
Staff
Registrado
4 Septiembre 2018
Ubicación
Valladolid
Buenas, con WinNFSd, comparto la carpeta de drive y me la ve el chinoppo, pero hay carpetas que no llega a ver el contenido y las que ve no reproduce.
Si comparto una sola carpeta con la peli, me la ve e intenta reproducirla pero llega al 100% de carga y ahí se queda.

No sé ya que más hacer.

Estoy por cancelar contrato (estoy en los 14 días, lo que no sé es el tema de la portabilidad de los móviles, si tendrá vuelta atrás) y volverme con Orange que me funcionaba con samba y me sigue reconociendo la red samba con su router, pero claro, no tengo internet y no puedo reproducir de drive. Me han hablado de poner el router en cascada pero ni idea de qué es ni como se hace y si tendría internet.
Te están diciendo la solución en el propio mensaje que citas. Las carpetas montadas de Drive no funcionan a través de NFS, sólo a través de Samba.

Y si estás usando WinNFSd significa que estás usando NFS.
Un saludo ;)
 

Koji

Miembro 1080i
Registrado
26 Julio 2019
He encontrado una "especie de solución" para que el chinoppo me coja la carpeta compartida drive desde windows. Tras intentarlo desde Linux, conseguí compartir la carpeta drive, pero no había forma que el chinoppo reconociera esa carpeta. Un poco cansado desistí y casi por casualidad, me di cuenta que cuando usaba el programa Zoom, para video llamadas, el chinoppo reconocía la carpeta drive compartida en Windows. No sé el motivo, pero si no abro este programa no me la reconoce, ni sé por qué si lo abro sí que me la reconoce, de hecho ni siquiera he tenido que activar el samba 1.0 en Windows.
No sé si puede funcionarle a alguien más, pero ahí lo dejo para aquellos que tengan o hayan tenido problemas lo prueben a ver. A mi por ahora, para ver de vez en cuando ver una peli en el chinoppo desde drive, me funciona. Si alguien es capaz de dar una explicación a por qué así me funciona, bienvenida sea, porque estoy bastante intrigado.

Saludos
 

franjhos

Miembro UHD SDR
Registrado
15 Septiembre 2018
He actualizado tanto el pc de mi hermana cómo el mío a Windows 10 mayo update.
Tras la actualización he tenido que ir a redes desde configuración
Opciones avanzadas y en la tercera pestaña deshabilitar la petición de contraseña que se había activado
Además me ha tocado cambiar los parámetros de las directivas locales de nuevo
Dejar conectarse a usuarios anónimos una de ellas y la otra algo de anónimo en cuentas Sam o algo así
Ahora ya vuelve a ir samba en un reproductor multimedia woxter icube 750
Con el cual desde hacía tiempo no aparecían las carpetas
En el chinoppo funciona bien el samba
Recordar habilitar smb 1.0 en característica de Windows si se hubiera deshabilitado
 

Reikai

Miembro 480p
Registrado
2 Enero 2020
Ubicación
CL
Para quienes tengan problemas con el samba del Windows 10 y el Chinoppo (rechaza la contraseña), añadiré algo de lo cual me he dado cuenta y que me ha resultado sin importar las actualizaciones o que cambie el router (lo he hecho) o sin asignar ip estática a mi laptop:

Llegado a la parte en la cual ya habilitan el SMBv1 en Windows 10, hacen click derecho en el icono de windows -> Administración de equipos:



En la columna izquierda, navegan a -> Usuarios y grupos locales -> Usuarios. Hacen click derecho en un espacio vacío y seleccionan "Usuario nuevo...":



Una vez ahí crean el nombre de usuario y contraseña, importante desmarcar la opción que dice "El usuario debe cambiar la contraseña en el siguiente inicio de sesión" y marcar la casilla que dice "La contraseña nunca expira". Le dan a crear.

Luego de esto al momento de compartir el disco que ustedes quieren o carpeta, recuerden incluir el usuario que han creado. Esto se puede evitar hacerlo utilizando sus mismos nombres de usuario y contraseñas de windows, pero sólo de usuarios locales. Luego al momento que el Chinoppo les pida usuario/contraseña para ingresar al recurso compartido, ingresan los mismos con los cuales crearon el usuario.

Si quieren ir a la segura, creen uno usuario nuevo de esa forma y ya, así es como lo hice hace meses y nunca me ha dado un problema. Así que eso es todo ! Espero les funcione para quienes aún tienen problemas.
 
Arriba