atragantamientos Videos 4K en Plex, Xplay, Kodi

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
Hola a todos, tengo una duda sobre "atragantamientos" de videos 4K máxima calidad en SONY OLED AG9 y me estoy volviendo loco.

- He probado con PLEX, XPLAY y KODI+Plex, en Calidad Original (nada de transcode).
- La peli es un MKV de 56GB (Alien 1979) en 4K y según dice la TV, bitrate de 65Mbps.
- TV conectada por cable, en red 10Gigabit (fibra 300/300). He hecho pruebas de velocidad en la TV y llega a 96Mbps. Teóricamente su límite 100Mbps.
- La peli está en servidor NAS a Gigabit

Pues es comenzar a verla, y se congela durante unos segundos... cada 5-10 segundos, pausa de 3. No tengo manera de solucionarlo.

Estoy muy mosqueado porque teóricamente el hardware soporta la peli, de sobras. No me gustaría NO tener que ver las pelis usando un reproductor externo (HTPC o similar) porque entendía que una TV así, podría reproducir con las apps adecuadas, pelis así...

¿Alguna idea? Muchas gracias por sugerencias!
 

lordpedro

Miembro 8K
Registrado
1 Mayo 2019
Yo esa peli me dió muchos problemas.Ya te digo yo que 65MBps no tiene,tiene muchos más.Al final sólo pude con reproductor externo.
A ver qué te dicen otros.
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Tu problema se llama ANDROID TV, es sin duda el peor S.O que hay en ese sentido (en mi opinión). Sí, le puedes instalar infinidad de chorriapps y juegos...pero no es el mejor sistema para reproducir este tipo de archivo.

Prueba a usar VLC, a mí es el único que es capaz de reproducir este tipo de archivos en mi NAS y con la Philips que tengo.
 

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
gracias por contestar... Android TV? También he probado alguna otra peli, calidad max, 60 GB... No pensé que no podría ver un archivo así en la TV. Lo que no quería es usar reproductor externo...

VLC en Android?
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Los televisores OLED de Sony vienen con Android TV.

Y sí, VLC está en Android.

Yo tengo una LG OLED C6 de hace casi tres años y puede con absolutamente todo.
 

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
yo con LG tuve una muy mala experiencia y WebOS tampoco me parece lo más, le has metido archivos de 60Gb y bitrates tan altos, por Red o NAS? Entiendo que la LG tiene 100/100 Mbit red como todas
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Pues WebOS es sin duda el mejor S.O de televisores que hay actualmente. No lo digo yo, ojo.

Todos los televisores actuales, desde el más barato al más caro, meten tarjetas de 100mb/sec. En principio te vale de sobra para todo. Alguna vez muy puntualmente he tenido un parón de un par de segundos reproduciendo por red desde mi NAS, que achaco a alguna saturación de red puntual (tengo conectados más de 30 dispositivos entre wifi y cable...así que un bun Router también es esencial).

Tengo archivos de 80GB, y sin problemas.
 

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
gracias, yo no creo que la red mía sea un problema (gigabit). Hay algo que no comprendo, si tu TV también será 100/100, ese archivo de 80GB, a menos que la peli dure mucho, tendrá picos de bitrate seguramente superiores... no se te atraganta? porque para eso están las cachés no?

Esto también lo podría probar, meter una caché al máximo, para aborber esos bitrates...

¿Cual es tu caso?
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
A veces el problema está en lo más insospechado. Tener una red Gigabit no garantiza nada. Un router malillo, un NAS poco eficiente, o usar el ordenador como Media Server, pueden ser orígenes de conflictos (me ha pasado todo eso).

Por supuesto, el propio gestor DLNA también está en el ajo. He tenido en el pasado muchos problemas con varios de ellos. Actualmente uso un NAS muy sencillito de WD con un disco duro de 4TB y usa de media server "Twonky Server", que no transcodifica ni genera problemas.

Como digo, he tenido algún caso de que se atasque al final de la peli, pero no necesariamente está vinculado con el que el archivo ocupe mucho (la fragmentación del archivo también es otro factor a considerar), sino a un atasco de la red o un momento de bitrate alto (aunque supuestamente no se superan nunca los 100mb/sec en los discos UHD actuales).

Sí, la caché está precisamente para evitar estos problemas, pero como digo, a veces no es eso.

Empieza por usar VLC, en mi Philips es el único reproductor que no da problemas. Si aún así sigues teniendo problemas, entonces tendrás que buscarlo en otro lado

Lo más sencillo es conectar un disco duro por USB y probar el archivo de forma directa. Así vas eliminando posibles candidatos.
 

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
mis experimentos en los primeros minutos de la peli, donde comienza a trabarse... con Mac utilidad NetworkX para medir la velocidad... y mira 10,1 MB/sec... Parece que la velocidad red / bitrate no debería ser el problema? Estoy mosca...
Alien_streaming.png
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Yo esa película la tengo y la he visto, y no he tenido problemas de reproducción. No confundas el bitrate con la velocidad de transferencia, ésta puede ser mayor porque tienes que añadir el bitrate del AUDIO y subtitulado (aunque sea marginal..es otra capa más a enviar). Tienes que analizar el bitrate con analizadores que lleven los reproductores de vídeo.
 

lordpedro

Miembro 8K
Registrado
1 Mayo 2019
Esa peli,si es la versión 40 aniversario le ha dado problemas a más de uno. Igual el NAS no tiene suficiente memoria. Igual tienes cable cat5 en lugar de cat5E...pueden ser muchas cosas. Lo del cable cat5 lo comento porque a mi me falló una película por eso,que 2 años con el cable pensando que era cat5E y de pronto me entero de que era cat5 a secas.En principio tampoco debería ser malo,pero a mi me falló.
 

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
@lordpedro @actpower gracias a los dos... Alien era solo el ejemplo, también me había pasado en otra Black Panther en plan "jabugo" de 50 GB y pasa lo mismo... Pero atención, como ha dicho @actpower VLC se la traga perfectamente en la TV! Estoy alucinando porque teóricamente PLEX y XPLAY deberían estar optimizadas no??

Pierdo todo el interface de PLEX, pero para las pelis, "jabugo" puedo ir así... (el Audio me lo pasa al Marantz 5.1 TrueHD DTS y esas cosas) así que perfecto...!
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Jeje, por qué crees que he insistido tanto con VLC?. Ya digo que Android es un poco pejiguero, y no siempre PLEX es lo mejor. Por supuesto, se pierden cosas por el camino, ¿pero qué más da si lo importante es que el archivo se reproduzca perfectamente?. Yo llevo usando años el reproductor de LG y es una mierda visualmente, pero es que me importa un bledo. Yo no quiero una interfaz bonita, quiero que se trague todo y sin rechistar. Y lo hace :)
 

rtaboraz

Miembro 480p
Registrado
2 Septiembre 2019
Jeje, por qué crees que he insistido tanto con VLC?. Ya digo que Android es un poco pejiguero, y no siempre PLEX es lo mejor. Por supuesto, se pierden cosas por el camino, ¿pero qué más da si lo importante es que el archivo se reproduzca perfectamente?. Yo llevo usando años el reproductor de LG y es una mierda visualmente, pero es que me importa un bledo. Yo no quiero una interfaz bonita, quiero que se trague todo y sin rechistar. Y lo hace :)
de verdad que flipando... pensaba que el VLC era un port, ya que es un viejo conocido, en plan la versión de Android, pero no uno tan optimizado para contenido high-end. Muchas gracias, he preguntado por ahí y tu respuesta es la acertada.

Ahora estoy configurando la app VLC como favorita de las TV, añadiendo las rutas como "favoritos" para que la señora / niños no se quejen. Volvemos a los 90s/00s con smb://

Muchas gracias :)
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Yo tampoco confiaba mucho en él, y a mí también me aconsejaron probarlo. Sí, lo de smb:// es kafkiano, pero funciona xD
 

davidvv

Miembro 1080i
Registrado
23 Junio 2019
de verdad que flipando... pensaba que el VLC era un port, ya que es un viejo conocido, en plan la versión de Android, pero no uno tan optimizado para contenido high-end. Muchas gracias, he preguntado por ahí y tu respuesta es la acertada.

Ahora estoy configurando la app VLC como favorita de las TV, añadiendo las rutas como "favoritos" para que la señora / niños no se quejen. Volvemos a los 90s/00s con smb://

Muchas gracias :)
Prueba tambien el reproductor ARCHOS si buscas interfaz tipo plex pruebalo porque yo lo uso en una sony de 2015 y tambien reproduzco pelis de alto bitrate y le configuras la carpeta de red como fuente y te descarga caratulas, posters subtitulos etc..
Algunas con problemas y otras sin ninguno.
Asi que tambien lo achaco a que la codificacion no sea de lo mejor, y que mi tv ya es antigua y con un hardware gama baja .
 

actpower

Miembro UHD SDR
Registrado
6 Agosto 2019
Ubicación
Madrid
Pues mira, he probado el Archos ese con la Philips que tengo que tiene Android TV y he trasteado con la gratuita y...

Lo primero, para las carátulas, o accedes por SMB, o por uPnP no es posible (eso pasa con todos). Sí es capaz de buscar en tiempo real si hay información y si el nombre del archivo es correcto. Solo lo he visto en un caso vía uPnP.

Bueno, he probado con uPnP a reproducir desde cosas a 1080p hasta lo más gordo y tocho que tengo. El resultado es bastante desastre. Los archivos M2TS van como el culo. Los MKV no van mal...hasta que ves que hay saltos de imagen (en 1080). Luego, si el audio es DTS, te dice que compres una licencia para escucharlos (!!!!). Los 4K activan el HDR pero las demos a 60FPS ni las carga, las pelis van bastante mal. Por SMB los resultados son iguales. Hay opciones para usar Software en vez de Hardware, ni me he molestado en usar esa opción. La de cambiar la frecuencia de refresco no funciona en Android TV, para variar.

Esa es mi experiencia. La de otros...ni idea.

Las mismas operaciones realizadas con VLC, han dado como resultado ningún problema. Pues eso.
 

davidvv

Miembro 1080i
Registrado
23 Junio 2019
Pues mira, he probado el Archos ese con la Philips que tengo que tiene Android TV y he trasteado con la gratuita y...

Lo primero, para las carátulas, o accedes por SMB, o por uPnP no es posible (eso pasa con todos). Sí es capaz de buscar en tiempo real si hay información y si el nombre del archivo es correcto. Solo lo he visto en un caso vía uPnP.

Bueno, he probado con uPnP a reproducir desde cosas a 1080p hasta lo más gordo y tocho que tengo. El resultado es bastante desastre. Los archivos M2TS van como el culo. Los MKV no van mal...hasta que ves que hay saltos de imagen (en 1080). Luego, si el audio es DTS, te dice que compres una licencia para escucharlos (!!!!). Los 4K activan el HDR pero las demos a 60FPS ni las carga, las pelis van bastante mal. Por SMB los resultados son iguales. Hay opciones para usar Software en vez de Hardware, ni me he molestado en usar esa opción. La de cambiar la frecuencia de refresco no funciona en Android TV, para variar.

Esa es mi experiencia. La de otros...ni idea.

Las mismas operaciones realizadas con VLC, han dado como resultado ningún problema. Pues eso.
todos esos problemas a mi no me han pasado, quiza es cosa del procesador, la cantidad y velocidad de la RAM para la cache de la phiilips.
Una pregunta, ademas del archos, tienes instalado su codec pack? hay que instalarlos los 2. quiza algunos de los problemas que comentas se resuelvan solo instalando el pack de codecs (que es gratuito tambien).
Fijate, yo conoci el archos precisamente porque el vlc de android de aquellas funcionaba como el culo y me dejaba la tele tostada continuamente, ya me acostumbre, y no he tenido la necesidad de buscar otro reproductor desde entonces, para que veas cuantos problemas de rendimiento tengo...
Que no digo que el VLC vaya peor, quiza ahora va como un tiro super optimizado pero hace 4 años era una MIERDA, con todas las letras, la version de android tv.

Otra cosa, yo las carpetas las tengo puestas por SMB y te hace el scrapping y te saca todo.
Y si de algun archivo te lo hace mal (poniendote la caratula por ejemplo de otra pelicula o incluso de alguna version de otro año como remakes y cosas de esas) o incluso no te la encuentra por que el nombre esta mal escrito o algo y puedes tu eso hacerlo a mano.

A mi esto me pasa con aprox el 5% de las pelis, pero claro son casi todo de dibujos animados para la peque y los cuentos clasicos, ademas de disney hay 25 versiones mas y con alguna se va la pinza.
Con peliculas es muy raro que no me coja los datos correctos a la primera. Es mas, con las series y los subtitulos si dejas el nombre del ripeador en el nombre de archivo y esas cosas, te baja el subtitulo de tu version.


Yo la unica peli que me da problemas y se lo achaco al codec porque otras que ocupan mas no me pasa, son los MKV a 1080 del señor de los anillos que ocupan 35gb. Y se lo achaco a los codec porque con pelis de 50 o 60GB 4k no me pasa.

Un saludo
 
Arriba