Tutorial Instalacion RCLONE en DSM

rober

Miembro 720p
Registrado
26 Marzo 2019
Yo lo tengo en xpenology (DSM) con el del primer post
Buenas, yo estoy siguiendo la guia del primer post pero cuando voy a crear el archivo de configuración ya no puedo seguir, sigo la guía


sudo /volume1/rclone/bin/rclone config

y siempre me sale command no found...

alguno sabe o cree saber donde he metido la pata?

saludos y gracias
 
Última edición:

leon2996

Miembro nuevo
Registrado
27 Noviembre 2019
Ya voy progresando adecuadamente.... mi version es la arm, no confundir con la arm64 que si no no funciona.. Ya os cuento luego si va o no.



Tengo la duda en lo siguiente:

client_id> (INTRO)
client_secret> (INTRO)
scope>1
root_folder_id> (INTRO)
service_account_file> (INTRO)

Supongo que hay que poner el client_id y el secret, no?


Entiendo que solo hay que darle a intro, y luego copiar y pegar en el navegador el link que te marcan para activar tu cuenta de Google Drive... Todo hecho sin problema...


EDITO:
La siguiente duda es esto que se marca en el script:

--config=PATH_DEL_PASO_5

Eso del pathdelpaso5 tengo que editar algo? Y cual es el paso 5, o no me lio y lo dejo como esta?



He dejado el script activado sin cambiar nada de la linea... he entrado en el Oppo por samba y no me aparece ni la carpeta Rclone, lo dejo así por si acaso tiene que hacer el cache.
Compañero has conseguido solucionar esto del PATH ?

Como se soluciona, no para de dar vueltas y no soy capar, ayudame por favor--
 

rober

Miembro 720p
Registrado
26 Marzo 2019
yo he conseguido montar la unidad con el procedimiento inicial, por ssh me ha visto todo el contenido e inicialmente se ha montado todo pero cuando accedo a la carpeta en DSM o algún dispositivo está totalmente vacia, no se que mas hacer
el tema del path si no me equivoco, o lo que probé yo, fue poner el resultado de cuando pone el comando
sudo /volume1/rclone/bin/rclone config file
pero como digo ha sido por probar, ni siquiera se si lo he hecho correctamente
 

Lambruzo

Miembro 1080p
Registrado
4 Julio 2019
photo5764651104523629544.jpg
Hola buenas , consigo crear todo por ssh, veo mi drive con todo el contenido , pero luego no soy capaz de ver la carpeta en synology , alguna idea ? He seguido todo el tutorial , monto la carpeta etc pero no soy capaz de que salga reflejada ,muchas gracias
 

Lambruzo

Miembro 1080p
Registrado
4 Julio 2019
Hola buenas , solucionado mi problema , creé la carpeta antes de iniciar el proceso , le dí permisos y la compartí y así me mostró la carpeta en el NAS
 

pepealvarez

Miembro 1080i
Registrado
5 Septiembre 2018
Hola compañeros
Parece que algunos compañeros están teniendo problemas con sus montajes de RCLONE, dicen que Google está "rechazando" aplicaciones que no usen autentificación OAuth 2.0 Por lo que en principio para solventarlo deberíamos editar nuestro/s remote/s añadiendo nuestras credenciales en el id_client y secret_id si en su día lo dejamos en blanco

El procedimiento no puede ser mas sencillo; para montar Rclone, tuvimos que crear en primer lugar un "proyecto" en https://console.developers.google.com/ y ahí habilitar la api de google drive. Al crear ese proyecto, nos obligó a crear unas credenciales OAuth, que son la que deberemos ir a buscar y añadir a nuestra configuracion de RCLONE.

Es tan simple como ir a https://console.developers.google.com/ loguearnos con nuestro usuario y contraseña y en el menu de la izquierda nos aparecerá una opción que es credenciales, clicamos sobre esa opción y nos mostrará nuestro proyecto, clicamos sobre el nombre de nuestro proyecto y nos mostrara tanto el id_client como el secret_id, así como la fecha de creación.

Copiamos esa info a cualquier editor de textos.

Y ya lo único que tendremos que hacer es editar la configuración de nuestro "remote" en RCLONE

Nos conectaremos a nuestro NAS o Raspberry por SSH con PUTTY, usuario y contraseña y el siguiente comando (para entrar en la configuración de RCLONE)

rclone config (en un syno)

cd /storage/.config/rclone/ (en una pi con LibreElec o similar)
./rclone config (en una pi con LibreElec o similar)

Lo primero que nos mostrara RCLONE nuestro/s remote/s y nos preguntara si queremos crear uno nuevo, editarlo, borrarlo, etc.
Optaremos por la opción E/ que es editarlo.
Y empezara por pedirnos el id_client , que estaba en blanco y ahora pegaremos el nuestro, a continuación el secret_id, también pegaremos el nuestro
Las siguientes opciones, diremos que no a editarlas

No editar scope
No editar root folder_id
No editar service_account_file
No Advanced config


Hasta que nos muestra un resumen de nuestra configuración y nos pregunta si es OK, optamos por Y

Refresh Token YES nos preguntara también si queremos refrescar el token le decimos que Y,
Usar la autoconfiguracion Ny

Copiaremos el link que nos aparece con botón izquierdo , y lo trasladamos al navegador y ahí copiamos el token y lo pegamos en putty con botón derecho

Por fin acabara mostrándonos la configuración, mostrándonos de nuevo el listado de remotes, instalados y preguntando si queremos editar, borrar, etc, elegimos Q, quit y nos vamos

Como solo hemos editado nuestro remote para añadir las credenciales OATH no precisamos, modificar nada en nuesta tarea programada (Synology) o autostart.sh (LibreElec); toda la configuración de RCLONE esta exactamente igual.

Todo, esto estaría mejor con unas imágenes, pero en definitiva, salvo añadir el id_cliente y secreto, el resto son los mismos parámetros que nos aportaron los cracks que abrieron este hilo y nos iluminaron (mi agradecimiento eterno a @mariopetit y @rsessa porque gracias a sus manuales fui capaz de instalar y configurar RCLONE.

Un saludo a todos y gracias infinitas a los que de verdad saben y comparten con nosotros su conocimientos y nosotros agotamos su paciencia

Pepe
 
Última edición:

gabriel69es

Miembro nuevo
Registrado
27 Febrero 2020
Buenas tarde compañeros... a ver si me podeis echar una mano en una duda que no salgo de ella. Cuando intento montar la unidad me da el siguiente error y no se como solucionarlo, me podriais ayudar?

pi@raspberrypi:~ $ 2020/02/27 17:47:09 mount helper error: fusermount: failed to access mountpoint /home/drive: Permission denied
2020/02/27 17:47:09 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

[1]+ Salida 1 /usr/bin/rclone mount -v drive: /home/drive --allow-non-empty --dir-cache-time 672h --vfs-cache-max-age 675h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 1G --buffer-size 32M


Si lo hago con SUDO me reporta el siguiente error.

pi@raspberrypi:~ $ sudo /usr/bin/rclone mount -v drive: /home/drive --allow-non-empty --dir-cache-time 672h --vfs-cache-max-age 675h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 1G --buffer-size 32M
2020/02/27 17:52:03 NOTICE: Config file "/root/.config/rclone/rclone.conf" not found - using defaults
2020/02/27 17:52:03 Failed to create file system for "drive:": didn't find section in config file


A ver si me podeis dar un poco de luz, gracias.
 

mariopetit

Miembro 720p
Registrado
6 Septiembre 2018
Buenas! Tienes que darle permisos a la carpeta /home/drive o crear el config de rclone con sido.
 

gabriel69es

Miembro nuevo
Registrado
27 Febrero 2020
Buenas!. Muchas gracias he echo las dos cosas y nada sigue dándome error en los permisos... No hay manera de montar la unidad.
 

rober

Miembro 720p
Registrado
26 Marzo 2019
a mi me funcionaba todo perfecto la verdad, pero el administrado cambio las autorizaciones para no usar rclone y la unidad me salia vacia, luego de que me lo autorizaran de nuevo no hay manera de volver a montarla, siempre que lo hago aparece vacia...hay alguna manera de eliminar las carpetas y empezar de 0?
 

gabriel69es

Miembro nuevo
Registrado
27 Febrero 2020
a mi me funcionaba todo perfecto la verdad, pero el administrado cambio las autorizaciones para no usar rclone y la unidad me salia vacia, luego de que me lo autorizaran de nuevo no hay manera de volver a montarla, siempre que lo hago aparece vacia...hay alguna manera de eliminar las carpetas y empezar de 0?
Hola, usa los siguientes comandos para eliminar carpetas

SUDO SU ( te convierte en administrador único )
rmdir /carpeta ( /nombre de la carpeta, si esta vacia )
rm –rf /carpeta ( /nombre de la cartera, si esta con archivos.... la ruta es /y donde esta la carpeta )

Depues sudo rclone config y d para eliminar y empezar de 0

Espero que te sea de ayuda.
 

rober

Miembro 720p
Registrado
26 Marzo 2019
Hola, usa los siguientes comandos para eliminar carpetas

SUDO SU ( te convierte en administrador único )
rmdir /carpeta ( /nombre de la carpeta, si esta vacia )
rm –rf /carpeta ( /nombre de la cartera, si esta con archivos.... la ruta es /y donde esta la carpeta )

Depues sudo rclone config y d para eliminar y empezar de 0

Espero que te sea de ayuda.
gracias!! Probaremos
 

miko6969

Miembro nuevo
Registrado
4 Mayo 2020
Hola buenas tardes,

Lo primero dar las gracias por los dos manuales para integrar gdrive en DSM. Yo he seguido el segundo método.
Veo las carpetas en FileStation pero no puedo copiar archivos en mi google drive. Es raro porque si que se pueden eliminar ficheros.
Buscando por Internet parece que es un bug:


A alguien le funciona o lo ha podido solucionar de alguna manera? please decirme como

Si no fuera posible desde File Station. Me surgen bastantes dudas que espero que podais solucionarme:

Como hacéis vosotros las copias y sincronizaciones entre el NAS y GDrive? Aplicaciones / Comandos.

Si lo hacéis con comandos, hay alguna forma de que se ejecute el comando desde el NAS sin tener que tener la conexión remota iniciada en otro equipo?

Gracias de antemano
Miko
 

pepealvarez

Miembro 1080i
Registrado
5 Septiembre 2018
Hola buenas tardes,

Lo primero dar las gracias por los dos manuales para integrar gdrive en DSM. Yo he seguido el segundo método.
Veo las carpetas en FileStation pero no puedo copiar archivos en mi google drive. Es raro porque si que se pueden eliminar ficheros.
Buscando por Internet parece que es un bug:


A alguien le funciona o lo ha podido solucionar de alguna manera? please decirme como

Si no fuera posible desde File Station. Me surgen bastantes dudas que espero que podais solucionarme:

Como hacéis vosotros las copias y sincronizaciones entre el NAS y GDrive? Aplicaciones / Comandos.

Si lo hacéis con comandos, hay alguna forma de que se ejecute el comando desde el NAS sin tener que tener la conexión remota iniciada en otro equipo?

Gracias de antemano
Miko
Holaaa, aunque RCLONE permite tambien subir archivos a tu cuenta de GoogleDrive, tienes una aplicacion nativa en DSM como Cloud Sync, que te permite subir desde tu NAS los arhivos que tengas en local a tu unidad de GoogleDrive y otros servicios de almacenamiento en la nube. El programa no precisa ejecutar nada en linea de comandos, es muy intuitivo y facil de usar, puedes programar las horas en que quieres que esos archivos se sincronicen, de esta forma si tienes mucho por subir puedes hacerlo poco a poco para no excecer los limites de subida de 750 Gb diarios.
Un saludo
 

miko6969

Miembro nuevo
Registrado
4 Mayo 2020
Gracias por la respuesta pepe, pero no me sirve Cloud Sync porque no puedo registar mi cuenta Team Drive y tampoco he podido añadir o no sé añadir la carpeta donde este montada . Solo me reconoce los 15Gb de espacio.

Como lo haceis vostros? que comandos usáis?
 

pepealvarez

Miembro 1080i
Registrado
5 Septiembre 2018
Gracias por la respuesta pepe, pero no me sirve Cloud Sync porque no puedo registar mi cuenta Team Drive y tampoco he podido añadir o no sé añadir la carpeta donde este montada . Solo me reconoce los 15Gb de espacio.

Como lo haceis vostros? que comandos usáis?
Hola, cierto, Cloud Sync no sirve para las unidades compartidas o "Team Drive", yo particularmente no uso Rclone para subida, siento no poderte ayudar
Un saludo
 

Mahedros

Miembro nuevo
Registrado
22 Junio 2020
Yo lo tengo en xpenology (DSM) con el del primer post
Buenos días,
Gracias por tu manual de rclone. Lo he seguido y veo la capeta montada de mi team google, pero lo que me pasa es que puedo eliminar y borrar contenido pero si quiero copiar o cargar entre carpetas del NAS me da el error: "esta acción no esta disponible"
Solo me pasa a mi?
Un saludo
 

xavinho

Miembro 480p
Registrado
9 Junio 2019
Buenas,
gracias por los manuales,yo monté todo perfectamente pero no me actualiza el contenido nuevo y no doy con la tecla.
Saludos.
 

jdeacon

Miembro 720p
Registrado
28 Noviembre 2018
Buenas, he vuelto a usar el manual de la primera pagina, solo que actualizando la version de Rclone al cogerlo de la pagina de Rclone downloads.
Luego mirare si esta todo como debe estar.

Por lo pronto no veo en filestation las carpetas creadas de Rclone y Drive, y la primera vez que lo hice en el otro nas hace un año se veían sin problema.

Desde ssh y mi usuario haciendo un "ls" se ven los directorios, marcados en verde todos, menos gdrive y rclone

Habría alguna manera de que se vieran? Porque si no no voy a poder acceder a ellos, no?
 
Arriba